其他反馈 默认的环境 Python 版本是 2.7 的,pip 版本也较低,如何都升级为最新的版本?

離桜 · 2018年10月16日 · 最后由 myx940925 回复于 2018年10月17日 · 337 次阅读

默认的环境Python版本是2.7的,pip版本也较低,如何都升级为最新的版本?

在创建环境的时候不能创建一个合适的环境,重新配置环境也巨麻烦,而且会出现各种问题?如何解决?

共收到 3 条回复

@lostsakura 您好,我们所提供的终端是一个完整的linux环境(Ubuntu 16.04.5).是可以根据自己的需求去升级的,比如您可以直接在终端执行pip install --upgrade pip去进行pip升级.您后面说的会出现各种问题能具体提出来吗

myx940925 回复

使用pip install --upgrade pip会出现路径错误等错误 卸载python2.7也会出现卸载不干净的情况(主要还是因为我是个小白) 我想要干净的原始环境,从头装配环境,有什么好的方法么?

離桜 回复

抱歉,我们所提供的标准环境都包含有python2.7,您具体的应用环境是什么呢?若使用python3.x直接安装就好了,并不需要去卸载2.7,然后pip install --upgrade pip尝试添加sudo执行下

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册
相关话题